Failed at the zigbee2mqtt@1.8.0 start script

Einrichtung der openHAB Umgebung und allgemeine Konfigurationsthemen.

Moderatoren: seppy, udo1toni

Benutzeravatar
sihui
Beiträge: 846
Registriert: 11. Apr 2018 19:03
Answers: 1

Re: Failed at the zigbee2mqtt@1.8.0 start script

Beitrag von sihui »

khaoohs hat geschrieben:
25. Jan 2020 13:14
Ergänzung - 2. mal npm start gibt folgende Meldung wieder:
Außer das man einen Service über systemd (oder hast du den Service nicht eingerichtet?) wie folgt neu startet (und nicht über npm)

Code: Alles auswählen

sudo systemctl start zigbee2mqtt
kann ich dir leider nicht mehr weiterhelfen. Ich hatte exakt die gleiche Fehlermeldung bei der ersten Installation und wie ich das beheben konnte habe ich schon geschrieben, sorry.
Vielleicht bist du im zigbee2mqtt Forum besser aufgehoben, da es hier ja nicht um openHAB geht.
openHAB2 mit Zwave, Tinkerforge, Alexa, ESP8266, Logitech Harmony, Philips HUE und Xiaomi Hardware

khaoohs
Beiträge: 20
Registriert: 14. Jan 2020 20:29

Re: Failed at the zigbee2mqtt@1.8.0 start script

Beitrag von khaoohs »

Ok, verständlich. Dennoch vielen Dank für die Unterstützung.

elysis
Beiträge: 22
Registriert: 17. Dez 2017 22:35

Re: Failed at the zigbee2mqtt@1.8.0 start script

Beitrag von elysis »

Hi,

hier viewtopic.php?f=15&t=3000 habe ich geschrieben mit welcher Kombination z2m am Besten läuft. Die Meldung, die Du bekommst deutet auch darauf hin, dass der Stick noch mal "überflasht" werden muss. Die Daten bleiben erhalten, aber er funktioniert danach wieder. Auch wenn zu viele Geräte gepaired sind, hat der Stick Probleme.

khaoohs
Beiträge: 20
Registriert: 14. Jan 2020 20:29

Re: Failed at the zigbee2mqtt@1.8.0 start script

Beitrag von khaoohs »

Danke sehr - den Stick habe ich nochmals überflasht - dann ging es auch. Wenn ich dann aber über npm start wieder in die Konsole bin kam dieser Output:
> zigbee2mqtt@1.9.0 start /opt/zigbee2mqtt
> node index.js

zigbee2mqtt:info 2020-01-30 20:25:41: Logging to console and directory: '/opt/zigbee2mqtt/data/log/2020-01-30.20-25-41'
zigbee2mqtt:info 2020-01-30 20:25:41: Starting zigbee2mqtt version 1.9.0 (commit #287f843)
zigbee2mqtt:info 2020-01-30 20:25:41: Starting zigbee-herdsman...
zigbee2mqtt:error 2020-01-30 20:25:54: Error while starting zigbee-herdsman
zigbee2mqtt:error 2020-01-30 20:25:54: Failed to start zigbee
zigbee2mqtt:error 2020-01-30 20:25:54: Exiting...
zigbee2mqtt:error 2020-01-30 20:25:54: Error: SRSP - SYS - version after 6000ms
at Timeout._onTimeout (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/utils/waitress.js:44:24)
at listOnTimeout (internal/timers.js:531:17)
at processTimers (internal/timers.js:475:7)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.9.0 start: `node index.js`
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the zigbee2mqtt@1.9.0 start script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! /home/openhabian/.npm/_logs/2020-01-30T19_26_30_031Z-debug.log

Nach einem "sudo reboot" folgendes:
> zigbee2mqtt@1.9.0 start /opt/zigbee2mqtt
> node index.js

zigbee2mqtt:info 2020-01-30 20:29:43: Logging to console and directory: '/opt/zigbee2mqtt/data/log/2020-01-30.20-29-43'
zigbee2mqtt:info 2020-01-30 20:29:44: Starting zigbee2mqtt version 1.9.0 (commit #287f843)
zigbee2mqtt:info 2020-01-30 20:29:44: Starting zigbee-herdsman...
zigbee2mqtt:info 2020-01-30 20:29:48: zigbee-herdsman started
zigbee2mqtt:info 2020-01-30 20:29:48: Coordinator firmware version: '{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190608}}'
zigbee2mqtt:info 2020-01-30 20:29:48: Currently 0 devices are joined:
zigbee2mqtt:warn 2020-01-30 20:29:48: `permit_join` set to `true` in configuration.yaml.
zigbee2mqtt:warn 2020-01-30 20:29:48: Allowing new devices to join.
zigbee2mqtt:warn 2020-01-30 20:29:48: Set `permit_join` to `false` once you joined all devices.
zigbee2mqtt:info 2020-01-30 20:29:48: Zigbee: allowing new devices to join.
zigbee2mqtt:info 2020-01-30 20:29:48: Connecting to MQTT server at mqtt://localhost
zigbee2mqtt:info 2020-01-30 20:29:48: Connected to MQTT server
zigbee2mqtt:info 2020-01-30 20:29:48: MQTT publish: topic 'zigbee2mqtt/bridge/state', payload 'online'
zigbee2mqtt:info 2020-01-30 20:29:48: MQTT publish: topic 'zigbee2mqtt/bridge/config', payload '{"version":"1.9.0","commit":"287f843","coordinator":{"type":"zStack12","meta":{"transportrev":2,"product":0,"majorrel":2,"minorrel":6,"maintrel":3,"revision":20190608}},"log_level":"info","permit_join":true}'

Protokollierung verstehe ich nicht.

Benutzeravatar
sihui
Beiträge: 846
Registriert: 11. Apr 2018 19:03
Answers: 1

Re: Failed at the zigbee2mqtt@1.8.0 start script

Beitrag von sihui »

khaoohs hat geschrieben:
30. Jan 2020 20:34
Nach einem "sudo reboot" folgendes:
Das sieht doch gut aus! Du solltest jetzt ein Gerät dem Netzwerk hinzufügen können.
openHAB2 mit Zwave, Tinkerforge, Alexa, ESP8266, Logitech Harmony, Philips HUE und Xiaomi Hardware

khaoohs
Beiträge: 20
Registriert: 14. Jan 2020 20:29

Re: Failed at the zigbee2mqtt@1.8.0 start script

Beitrag von khaoohs »

Ja, in der Tat. Nach langem hin und her habe ich es nun hinbekommen. Ich vermute ich habe jedes mal beim Installieren das Passwort (pi:pi) welches in einer Installationsanweisung hinterlegt war nicht abgeändert. Bei der letzten Installation bin ich darüber gestolpert und habe dies beachtet und seitdem geht's. Danke Euch für die Unterstützung, hätte sonst schon den Kopf in den Sand gesteckt.
Was allerdings als noch kommt ist diese Protokollierung:
igbee2mqtt:error 2020-01-30 20:25:54: Error: SRSP - SYS - version after 6000ms
at Timeout._onTimeout (/opt/zigbee2mqtt/node_modules/zigbee-herdsman/dist/utils/waitress.js:44:24)
at listOnTimeout (internal/timers.js:531:17)
at processTimers (internal/timers.js:475:7)
npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! zigbee2mqtt@1.9.0 start: `node index.js`
npm ERR! Exit status 1

Ist aber nur temporär, dann geht es wieder...

Antworten