Fehlermeldung "..expecting RULE_ID.." help needed

Alles zu Rules, Items, Sitemaps unter openHAB 1.X

Moderatoren: seppy, udo1toni

Antworten
franzda
Beiträge: 3
Registriert: 9. Jun 2019 21:12

Fehlermeldung "..expecting RULE_ID.." help needed

Beitrag von franzda » 9. Jun 2019 21:32

Ich bekomme folgende Fehlermeldung die ich nicht erklären kann.

Wie findet man die Ursache dafür. Wie definiere ich wenn ein Wert durch rules bearbeitet werden soll (die zwei letzten Werte in der Items Datei im Anhang)

Werte von der Fritz Box haben channel Definition ...


2019-06-09 21:22:54.345 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'fritz.items' has errors, therefore ignoring it: [14,7]: mismatched input ' ' expecting RULE_ID

[15,7]: extraneous input ' ' expecting RULE_ID

2019-06-09 21:22:55.430 [WARN ] [el.core.internal.ModelRepositoryImpl] - Configuration model 'fritz.items' has errors, therefore ignoring it: [14,7]: mismatched input ' ' expecting RULE_ID

[15,7]: extraneous input ' ' expecting RULE_ID
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Stefan Otten
Beiträge: 64
Registriert: 11. Nov 2018 06:51

Re: Fehlermeldung "..expecting RULE_ID.." help needed

Beitrag von Stefan Otten » 10. Jun 2019 09:03

Hallo,

jede Rule benötigt auch einen eigenen Namen.
Diesen definierst Du mit:
rule "Name der Rule"
Siehe dazu auch: https://www.openhab.org/docs/configurat ... s-dsl.html

Schöner wäre es, wenn Du Deine Codes nicht als Datei anhängst, sondern im Editor des Forums mit der Code-Funktion darstellst.
Das ist das </> Symbol im Editor Menü.


Grüße

Benutzeravatar
udo1toni
Beiträge: 1673
Registriert: 11. Apr 2018 18:05
Wohnort: Darmstadt

Re: Fehlermeldung "..expecting RULE_ID.." help needed

Beitrag von udo1toni » 11. Jun 2019 01:18

Du hast in Deiner fritz.items seltsame Steuerzeichen (die führen bei mir zuverlässig dazu, dass ich keinen Text hinzufügen kann - seltsam - dass teilweise (nur teilweise!!!) statt Leerzeichen erweiterte Leerzeichen stehen, außerdem ist die Datei in ANSI codiert. Das ist nur in Ordnung, wenn Dein openHAB auf einer Windows Büchse läuft.

In der rules-Datei fehlt vorne am Import das i. Abgesehen davon ist der import unnötig, außerdem ist er nicht erlaubt (es sei denn, Du setzt openHAB1.x ein)

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast