Probleme beim flashen

Moderator: udo1toni

Antworten
madmike
Beiträge: 208
Registriert: 15. Apr 2018 17:09

Probleme beim flashen

Beitrag von madmike » 8. Aug 2019 11:13

Hallo zusammen,

ich bräuchte mal wieder einen Tipp von Euch.
Nach dem Update meines Rechners auf das neuste Windows 10 release kann ich nicht mehr mit AtomIO und PlatformIO compilieren oder flashen.
Darauf habe ich VSCode installiert, PlatformIO ebenfalls als Extension.
Aber auch hier fehlen mir anscheinend irgendwelche Dateien. Ich kann das Projekt laden und bearbeiten, aber nicht compilieren oder flashen. Es fehlt die Toolbar unten. Im Netz gibt es Anleitungen die aber ein neues Projekt machen und nicht ein vorhandenes aufrufen. Hier wird nach erstellen des Projektordners und des Projekt Dateien zusätzlich geladen und installiert die dann das flashen möglich machen. Es scheint bei bestehenden Projekten nicht zu gehen.
Wer hat einen Tipp ???
Ich würde gerne in Zukunft mit VSC arbeiten.
Danke im Voraus
madmike

madmike
Beiträge: 208
Registriert: 15. Apr 2018 17:09

Re: Probleme beim flashen

Beitrag von madmike » 8. Aug 2019 14:22

Hier auch einmal die Fehlermeldung:

Bild

Vielen Dank für Eure Mühe
Madmike
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

faximan
Beiträge: 10
Registriert: 17. Aug 2019 12:49

Re: Probleme beim flashen

Beitrag von faximan » 19. Aug 2019 21:35

Willst Du Tasmota flashen oder eigene Sketches?

Benutzeravatar
peter-pan
Beiträge: 339
Registriert: 28. Nov 2018 12:03
Wohnort: Schwäbisch Gmünd

Re: Probleme beim flashen

Beitrag von peter-pan » 20. Aug 2019 17:35

Schau mal hier. Vielleicht hilft dir das weiter (RX an TX und TX an RX)

Heavy-Dee
Beiträge: 63
Registriert: 18. Jan 2018 16:38

Re: Probleme beim flashen

Beitrag von Heavy-Dee » 14. Sep 2019 17:30

Muss meine Sonoffs neu flashen ! (nach update auf 6.6.0 -> kein zugriff mehr)
Atom funktioniert auf meinem Win10 PC nicht mehr. Wollte es mit VSC probieren, aber flash funktioniert nicht.
Folgende Fehlermeldung:
platformio-fehler.JPG
Kann mir jmd helfen?
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
openHab2 (v. 2.3.0.005) auf Synology DS216II [+Mosquitto MQTT (v. 1.4.14-9)] :!:
Test: openHab2 (v. 2.4) + [embedded-mqtt-broker] auf Windows 10 :?:

Benutzeravatar
peter-pan
Beiträge: 339
Registriert: 28. Nov 2018 12:03
Wohnort: Schwäbisch Gmünd

Re: Probleme beim flashen

Beitrag von peter-pan » 14. Sep 2019 19:47

Was heisst kein Zugriff mehr ? Von wo aus ? Kannst du deine Sonoffs noch über die WebUI erreichen ? Wie hast du auf 6.6 geflasht ?

madmike
Beiträge: 208
Registriert: 15. Apr 2018 17:09

Re: Probleme beim flashen

Beitrag von madmike » 14. Sep 2019 22:26

Hallo Peter-Pan,

danke für Deine Idee, aber das ist nicht das Problem. Wenn ich es richtig verstanden habe hat sich was bei PlatformIO geändert nach dem letzten Update funktioniert es nicht mehr. Ich weiss bisher leider nicht was genau passiert ist. Schau mal unter den Fehler Logs der Bilder Heavy Dee bekommt den gleichen Fehler und kann seine Datei ebenfalls nicht Compilieren
Vielleicht weiss jemand was sich bei dem Update von platformIO geändert hat ??

mfg
Madmike

Heavy-Dee
Beiträge: 63
Registriert: 18. Jan 2018 16:38

Re: Probleme beim flashen

Beitrag von Heavy-Dee » 15. Sep 2019 10:08

Also ich habe bisher 3 Sonoffs über die das WebUI mit fertige "sonoff-DE.bin" geupdated.
Beim ersten mit "sonoff-DE.bin" folgende Fehlermeldung
update-fehler.JPG
, also nochmal über "sonoff-minimal.bin" + "sonoff-DE.bin" => alle Einstellungen übernommen (incl. WLAN Einstellungen) : i.O.
Beim zweiten: "sonoff-minimal.bin" + "sonoff-DE.bin" => keine WLAN Einstellungen übernommen (über SonoffAP WLAN neu eingestellt) : i.O.
Beim dritten: "sonoff-minimal.bin" + "sonoff-DE.bin" => keine WLAN Einstellungen übernommen (über SonoffAP WLAN neu eingestellt) : i.O.
Beim vierten: "sonoff-minimal.bin" => KEIN Zugriff mehr auf WebUI und KEIN SonoffAP -> also über FTDI neu flashen, beim kompilieren über Atom oder VSC folgende Fehlermeldung
platformio-fehler.JPG
.
Habe den vierten mittlerweile mit "NodeMCU-PyFlasher" die "sonoff-DE.bin" geladen => funktioniert wieder.
Würde mir aber gerne eine individuelle "sonoff.bin" mit meinen Einstellungen erstellen !!
Ich glaube auch sich bei dem Update von platformIO etwas geändert hat, da es mit ATOM auch nicht mehr funktioniert.

Nachtrag:
Beim fünften: "sonoff-minimal.bin" : i.O -> "sonoff-DE.bin" => KEIN Zugriff mehr auf WebUI und KEIN SonoffAP
Also wieder ausbauen, öffnen und "NodeMCU-PyFlasher" dran.
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
openHab2 (v. 2.3.0.005) auf Synology DS216II [+Mosquitto MQTT (v. 1.4.14-9)] :!:
Test: openHab2 (v. 2.4) + [embedded-mqtt-broker] auf Windows 10 :?:

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast