Openhab. Service restart komische Meldung

Hier bitte alles rein was Off-topic ist.

Moderatoren: Cyrelian, seppy

Antworten
dreamar
Beiträge: 42
Registriert: 22. Dez 2017 08:41

Openhab. Service restart komische Meldung

Beitrag von dreamar »

Hallo

kann mir einer sagen was diese Meldung zusagen hat bei einem "sudo System til restart openhab.service"?
Oft bekomme ich danach Probleme mit meinem deconz für Zigbee
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.
Openhab 2.5.8 mit deconz und Homematic

Benutzeravatar
udo1toni
Beiträge: 4338
Registriert: 11. Apr 2018 18:05
Answers: 46
Wohnort: Darmstadt

Re: Openhab. Service restart komische Meldung

Beitrag von udo1toni »

Ich gehe mal davon aus, dass das verwendete Kommando

Code: Alles auswählen

sudo systemctl restart openhab2.service
lautet :)
Es gibt hier verschiedene Möglichkeiten.

Nutzt Du das verzögerte Laden der Rules beim Start von openhAB? (da gibt es eine Option in openhabian-config). das könnte zu diesem Verhalten führen.
Es kann aber auch sein, dass Du eine fehlerhafte Version von systemd einsetzt, ich hab da vor ein paar Tagen durch Zufall einen Issue dazu gelesen...

Du kannst schauen, ob ein

Code: Alles auswählen

sudo systemctl daemon-reload
die Meldung (dauerhaft) beseitigt. Auswirkungen auf deconz dürfte die Meldung nicht haben, da vermute ich eher ein unglückliches Zusammenspiel der verschiedenen Dienste. Keine Ahnung, welche Startreihenfolge hier einzuhalten ist.

Mowgli
Beiträge: 26
Registriert: 30. Jan 2019 13:47

Re: Openhab. Service restart komische Meldung

Beitrag von Mowgli »

Hallo,

wenn ich mein Openhab System neu komplett neu boote (zum glück selten) sind nach dem Start einige deconz items offline.
Wahrscheinlich ist da der openhab service schneller als deconz das Zigbee Netz zusammengepuzzelt hat. Wenn ich dann 2 min warte und die openhab service neu starte ist alles fein.

Müsste mal sehen ob ich den Start des openhab service verzögern kann.

Grüße

Mowgli

Benutzeravatar
udo1toni
Beiträge: 4338
Registriert: 11. Apr 2018 18:05
Answers: 46
Wohnort: Darmstadt

Re: Openhab. Service restart komische Meldung

Beitrag von udo1toni »

Wie hast Du den Rechner aufgesetzt? openHABian sollte eigentlich automatisch entsprechende Denkpausen einlegen.

Mowgli
Beiträge: 26
Registriert: 30. Jan 2019 13:47

Re: Openhab. Service restart komische Meldung

Beitrag von Mowgli »

Hallo,

bei mir ist der Rechner ist ein Intel NUC mit Ubuntu lts. openHABian habe ich per Script manuell drauf gepackt.
Ich kann mit dem Problem leben, ist bekannt und kann umschifft werden.
Will über kurz oder lang auf Docker wechseln, dann in passender Reihenfolge im die Container starten und alles ist gut.

Grüße

Mowgli

Antworten