MagicHomeLED mit Tasmota in Openhab einbinden

Die alternative Firmware für ESP8266 based devices

Moderatoren: seppy, udo1toni

Antworten
eric1905
Beiträge: 2
Registriert: 14. Apr 2020 12:40

MagicHomeLED mit Tasmota in Openhab einbinden

Beitrag von eric1905 »

Hallo zusammen,
ich bin noch recht neu in Openhab und versuche mein mit Tasmota geflashtes LEDBand per MQTT in Openhab einzubinden.

Die Dateien sehen wie folgt aus:
Things:

Code: Alles auswählen

    Thing topic rgb_led_bild "RGB Led Bild" @ "Jonas" {
    Channels:
        Type switch   : power      "Power"                  [ stateTopic="Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/POWER", commandTopic="Haus/Erdgeschoss/Wohnzimmer/LEDBand/cmnd/POWER" ]
        Type dimmer   : dimmer     "Dimmer"                 [ stateTopic="Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT", commandTopic="Haus/Erdgeschoss/Wohnzimmer/LEDBand/cmnd/DIMMER", transformationPattern="JSONPATH:$.Dimmer" ]
        Type colorHSB : colour     "Farbe"                  [ stateTopic="Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT", commandTopic="Haus/Erdgeschoss/Wohnzimmer/LEDBand/cmnd/HSBColor", transformationPattern="JSONPATH:$.HSBColor" ]
    }
Items:

Code: Alles auswählen

Group    RGB_Led_Bild               "LED Bild"       
Switch   RGB_Led_Bild_Power       "Power: [%s]"                     (RGB_Led_Bild)   {channel="mqtt:topic:mosquitto:rgb_led_bild:power"}
Dimmer   RGB_Led_Bild_Dimmer      "Dimmer:"                         (RGB_Led_Bild)  {channel="mqtt:topic:mosquitto:rgb_led_bild:dimmer"}
Color    RGB_Led_Bild_Colour      "Farbe:"                          (RGB_Led_Bild)  {channel="mqtt:topic:mosquitto:rgb_led_bild:colour"}
Sitemap:

Code: Alles auswählen

	Switch item=RGB_Led_Bild_Power label="LEDBand: [%s]" icon="light"
        Colorpicker item=RGB_Led_Bild_Colour label="Bild Farbe:"
        Default item=RGB_Led_Bild_Dimmer label="Dimmer:"

Das ganze sieht dann so aus wie im Anhang.
Wenn ich im Colorpicker den slider unten ändere für eine andere Helligkeit, setzt er zwar die Helligkeit der LEDs, der Slider springt aber sofort danach auf 50.
Wenn ich nun eine andere Farbe auswähle wird diese gesetzt, allerdings mit dem Wert Dimmer=50, obwohl der Dimmer vorher ja auf 100 war.

Ablauf:

Code: Alles auswählen

LEDs sind über Tasmota auf Rot gesetzt
16:33:50 MQT: Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT = {"POWER":"ON","Dimmer":100,"Color":"FF0004","HSBColor":"359,100,100","Channel":[100,0,2]}

Ich aktualisiere meine basicui und sehe wenn ich auf den colorpicker sehe die Farbe auf Rot und den Slider auf 100%. Der extra Wert für Dimmer ist ebenfalls bei 100%
Ich setze den Wert auf blau und alles ist ok.

16:37:26 MQT: Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT = {"POWER":"ON","Dimmer":100,"Color":"0314FF","HSBColor":"236,99,100","Channel":[1,8,100]}
ich schließe das fenster und öffne es wieder, der Colorpicker zeigt auf weiß, der slider unter dem colorpicker auf 50%. Der extra wert für Dimmer steht noch auf 100%


Ich setze den Wert wieder auf Blau und den slider unterhalb auf etwa 75%
16:38:32 MQT: Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT = {"POWER":"ON","Dimmer":50,"Color":"070D80","HSBColor":"237,95,50","Channel":[3,5,50]}
16:38:34 MQT: Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT = {"POWER":"ON","Dimmer":78,"Color":"0A14C7","HSBColor":"237,95,78","Channel":[4,8,78]}
Wie man sieht wurde beim "auf blau setzen" der Dimmer auf 50% übermittelt, obwohl ich ihn nicht verändert habe.  Der Zweite befehl wo ich ihn dann per hand setze wird korrekt an tasmota übermittelt, allerdings in basicui wieder auf 50 gesetzt sodass beim nächsten Farbwechsel wieder eine Helligkeit von 50% entsteht.

Ich hab also zum einen 2 Probleme.
1. Beim Öffnen vom Colorpicker ist der kreis zum selektieren manchmal in der Mitte und manchmal auf dem Richtigen Wert
2. Die Helligkeit wird auf 50% gesetzt und verfälscht spätere Werte


Ich hoffe hier kann mir jemand weiterhelfen woran das liegen könnte.

Benutze openHAB 2.5.4 Release Build
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

eric1905
Beiträge: 2
Registriert: 14. Apr 2020 12:40

Re: MagicHomeLED mit Tasmota in Openhab einbinden

Beitrag von eric1905 »

Ok, Im log sehe ich folgendes:
2020-05-05 18:28:15.752 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.Dimmer' in '{"POWER":"OFF"}'
2020-05-05 18:28:15.753 [WARN ] [t.generic.ChannelStateTransformation] - Executing the JSONPATH-transformation failed: Invalid path '$.HSBColor' in '{"POWER":"OFF"}'

liegt es am topic Haus/Erdgeschoss/Wohnzimmer/LEDBand/stat/RESULT
sollte ich hier auf tele gehen? Habe auch mal gesehen man könne hier 2 channels im thing machen und in einem item zusammenfassen. Macht das hier sinn?

Antworten