NTP Item zeigt keine Zeit

Allgemeine Fragen zum Thema "Smart Home" und Entscheidungshilfen

Moderator: seppy

Antworten
Vikarowitsch
Beiträge: 7
Registriert: 14. Apr 2021 18:13

NTP Item zeigt keine Zeit

Beitrag von Vikarowitsch »

Hallo
Als Newbie versuche ich mich in die OH3 GUI Konfiguration einzuarbeiten. Hardware: RPI.
Aktuell habe ich über das NTP Binding ein Thing kreiert, welches online ist:
ThingChannel.png
Bild

Im openhab-cli showlogs wird die Zeit aktualisiert:
2021-12-27 08:48:27.292 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'NTPServer_DateTimeString' changed from 2021-12-27 08:47:27 CET to 2021-12-27 08:48:27 CET

Kreiere ich nachher ein Item bleibt dieses aber leer:
NtpItemLeer.png
Kann mir jemand ein Tipp geben?
Danke und Gruss
Vik
von peter-pan » 31. Dez 2021 11:56
...evtl. Pi nochmal starten bzw. in der Konsole eingeben "sudo systemctl restart openhab". Vorher aber in der Administrations-UI abmelden.

Ggf. reicht auch "Anwendung neu laden" in der UI unter "Über & Hilfe".

Sonst fällt mir nichts ein.
Gehe zur vollständigen Antwort
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Benutzeravatar
peter-pan
Beiträge: 2121
Registriert: 28. Nov 2018 12:03
Answers: 20
Wohnort: Schwäbisch Gmünd

Re: NTP Item zeigt keine Zeit

Beitrag von peter-pan »

Irgendwie gibt's da kleine Unstimmigkeiten in deinem Post. Im Log ist die Rede von einem Item "NTPServer_DateTimeString", in deinem Screeshot heisst das Item nur "NTPServer_DateTime".

Das sind aber eigentlich 2 verschiedene Channels!

Vikarowitsch
Beiträge: 7
Registriert: 14. Apr 2021 18:13

Re: NTP Item zeigt keine Zeit

Beitrag von Vikarowitsch »

Ich versuche mit folgendem Link
https://bangertech.de/openhab-3-tutoria ... umuhrzeit/
das Wissen aufzubauen.
Da es nicht funktionierte habe ich in der Logdatei gesehen dass "etwas" funktioniert.
Wo es aber falsch ist erschließt sich mir nicht!
Ich bin ratlos.
Ist den die Beschreibung im Link schlüssig richtig?

Benutzeravatar
peter-pan
Beiträge: 2121
Registriert: 28. Nov 2018 12:03
Answers: 20
Wohnort: Schwäbisch Gmünd

Re: NTP Item zeigt keine Zeit

Beitrag von peter-pan »

Ich habe das mal auf einer neuen OH3-Installation "nachgebaut" und das passt eigentlich schon. Eine Änderung des Things bzw. des Änderingsintervalls und der Abfragefrequenz halte ich allerdings nicht für nötig (aber das ist Geschmackssache).
Ich habe die Punkte ab "Add Link to Item" noch einmal nachvollzogen, wobei (DateTime-Channel):
item6.jpg
Wenn du, wie unter Bild 1(Nr 1. im oberen Screenshot) auf "Link" klickst (du hast "create new item" ausgewählt), erscheint Nr.2 und da klickst du auf das Datum.
Damit wechselst du sozusagen in die Items-Pflege(Nr. 3.) und nachdem du hier auf "Metadaten geklickt hast, erscheint eine Auswahl mit Möglichkeiten. Du entscheidest dich in diesem Falle für "stateDescription" und kannst dann, wie in Nr. 4. zu sehen deinen gewünschten Pattern/Suffix/Formatierung eingeben.

Das Ergebnis sieht dann so aus:
item5.jpg
Da ich in den System-Einstellungen noch "Englisch" stehen habe, wird der Tagesname noch in englisch ausgegeben (Neue Installation ;) )

Grundsätzlich nutze ich aber die "alte Variante" mittels Textkonfiguration.

ntp.things

Code: Alles auswählen

//		NTP - Binding - Uhrzeit

ntp:ntp:local "Isny in Kur gewesen" @ "Datum - Uhrzeit"	[hostname="0.pool.ntp.org", refreshInterval=60, refreshNtp=30, serverPort=123, timeZone="Europe/Berlin" ]
ntp.items

Code: Alles auswählen

DateTime      Current_DateTime  "Heute [%1$tA, %1$td.%1$tm.%1$ty,%1$tH:%1$tM]"      <calendar> (gHome)      ["Status"]     {channel="ntp:ntp:local:dateTime"}
String        Current_String    "Heute ist            [%s]"                                                 ["WebService"] {channel="ntp:ntp:local:string"}
Du hast keine ausreichende Berechtigung, um die Dateianhänge dieses Beitrags anzusehen.

Vikarowitsch
Beiträge: 7
Registriert: 14. Apr 2021 18:13

Re: NTP Item zeigt keine Zeit

Beitrag von Vikarowitsch »

Danke für die detaillierte Beschreibung.
Genau so habe ich es auch gemacht. Mein Bild 2 sieht aber so aus:

Bild

Was auffällt ich habe keine Icons und der Zeitstempel fehlt schon hier!

Zum aktuellen Systemzustand ist zu sagen:
Ich habe bis jetzt einfach chaotisch learning by doing gemacht. :roll:
Things/Items/Bindings usw kreiert entfernt geändert. Einfach alles was möglich war.

Sollte ich eine Neuinstallation in Betracht ziehen?
Dazu die Frage:
Gibt es eine einfache Möglichkeit alle Things/Items zu löschen und quasi neu zu beginnen ohne eine komplette Neuinstallation zu starten?

Vikarowitsch
Beiträge: 7
Registriert: 14. Apr 2021 18:13

Re: NTP Item zeigt keine Zeit

Beitrag von Vikarowitsch »

FollowUp:

Habe gefunden wie alles gelöscht werden kann:
Oben rechts im Titel: Select, dann alles auswählen, dann Remove
  • Items entfernt
    • Things entfernt
    • Binding entfernt
    • RPI neu starten
    Das System ist "jungfräulich" bis auf System-Einstellungen
    • Binding NTP installieren
    • Thing kreieren wie beschrieben
    • Item kreieren wie beschrieben. Beide Channels
    • Logfile:
      2021-12-31 08:44:25.753 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'LocalTime_DateTime' changed from 2021-12-31T08:43:25.733+0100 to 2021-12-31T08:44:25.736+0100
      2021-12-31 08:44:25.757 [INFO ] [openhab.event.ItemStateChangedEvent ] - Item 'LocalTime_String' changed from 2021-12-31 08:43:25 CET to 2021-12-31 08:44:25 CET
    • Resultat: Immer noch keine Zeit im Item

    Benutzeravatar
    peter-pan
    Beiträge: 2121
    Registriert: 28. Nov 2018 12:03
    Answers: 20
    Wohnort: Schwäbisch Gmünd

    Re: NTP Item zeigt keine Zeit

    Beitrag von peter-pan »

    ...evtl. Pi nochmal starten bzw. in der Konsole eingeben "sudo systemctl restart openhab". Vorher aber in der Administrations-UI abmelden.

    Ggf. reicht auch "Anwendung neu laden" in der UI unter "Über & Hilfe".

    Sonst fällt mir nichts ein.

    Vikarowitsch
    Beiträge: 7
    Registriert: 14. Apr 2021 18:13

    Re: NTP Item zeigt keine Zeit

    Beitrag von Vikarowitsch »

    Follow Up:
    Neuinstallation und Versuch das Datum anzuzeigen.
    Ergebnis: Alles funktioniert.

    @peter-pan: Dank für die Unterstützung.
    @all: Häbbi niu ier :D (Happy New Year)

    Antworten