Raspi Pi4 hat 2 ip Adressen

Moderatoren: seppy, udo1toni

Antworten
Locke
Beiträge: 165
Registriert: 14. Apr 2020 11:35
Answers: 3
Wohnort: bei Hamburg

Raspi Pi4 hat 2 ip Adressen

Beitrag von Locke »

Gumo,
mein Raspi hat im Netzwerk plötzlich 2 ip Adressen. Er hat normal eine feste IP Adresse 192.168.123.141 und lief auch immer damit, jetzt hat er noch die .143 dazubekommen wenn ich ein Netzwerkscan mache.
Es Ist mir aufgefallen als ich auf den OH3 server anmelden wollte und es nicht klappte. Jetzt ist er erreichbar unter .141 und .143

Wie bekomme ich die .143 wieder weg ?
Könnt ihr mir eine Hilfestellung geben, danke

Im Router/Modem steht unter Statische DHCP auch nur die 192.168.123.141
In der Übersicht der angeschlossenen Geräte taucht die 192.168.123.143 auf

Code: Alles auswählen

openhabian@openHABianDevice:~ $ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether dc:a6:32:0a:c5:b6 brd ff:ff:ff:ff:ff:ff
    inet 192.168.123.143/24 brd 192.168.123.255 scope global dynamic noprefixroute eth0
       valid_lft 3271sec preferred_lft 3271sec
    inet 192.168.123.141/24 brd 192.168.123.255 scope global secondary noprefixroute eth0
       valid_lft forever preferred_lft forever
    inet6 2a02:8108:1500:6594:c870:e036:805e:8fb/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86384sec preferred_lft 43184sec
    inet6 2a02:8108:1500:6594::f269/128 scope global dynamic noprefixroute 
       valid_lft 42478sec preferred_lft 42478sec
    inet6 2a02:8108:1500:6594:d705:f192:ce1c:883c/64 scope global dynamic noprefixroute 
       valid_lft 86398sec preferred_lft 43198sec
    inet6 fe80::46c7:34c0:5fb8:3bf7/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlan0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether ee:46:f5:de:25:09 brd ff:ff:ff:ff:ff:ff

unter "/etc/dhcpcd.conf " habe ich folgende Einträge

Code: Alles auswählen

interface eth0
static ip_address=192.168.123.141/24
#static ip6_address=fd51:42f8:caae:d92e::ff/64
static routers=192.168.123.1
#static domain_name_servers=192.168.0.1 8.8.8.8 fd51:42f8:caae:d92e::1
static domain_name_servers=192.168.123.1
thnx
____Sven_________________________________________________________________________________________
Raspberry Pi 4, 4GB RAM, openHAB 2.5.10 / Raspberry Pi 4, 2GB RAM, openHAB 3.3.0 (zum Testen)

Benutzeravatar
KellerK1nd
Beiträge: 392
Registriert: 17. Jun 2019 16:45
Answers: 1
Wohnort: Griesheim

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von KellerK1nd »

Ist im Router auch eine feste IP vergeben? So wie es aussieht bekommt er vom DHCP Server die IP.
eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether dc:a6:32:0a:c5:b6 brd ff:ff:ff:ff:ff:ff
inet 192.168.123.143/24 brd 192.168.123.255 scope global dynamic noprefixroute eth0
valid_lft 3271sec preferred_lft 3271sec
Da läuft ein Lease auf der Addresse, das heißt das kommt in der Regel vom DHCP-Server. Mal den Router neu starten?
Betriebssystem: Proxmox 7.2-3
openHAB Container: debian11 LXC
openHAB Version: 3.3
Hardware: HomeServer Eigenbau mit einem Intel i5 9600K
Smarthome-Equipment:
- Rasperrymatic
- deConz
- HUE
- Shellys
- Mosquitto
- AVM Fritz!Box

Benutzeravatar
udo1toni
Beiträge: 9813
Registriert: 11. Apr 2018 18:05
Answers: 131
Wohnort: Darmstadt

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von udo1toni »

Die Frage ist eher, ob der DHCP Client zusätzlich auf dem Interface aktiv ist. Der Router mag bei Anfragen eine andere Adresse vergeben, im Pi selbst taucht diese aber nur auf, wenn der Pi auch einen DHCP Request schickt.
openHAB2.5.12 in einem Debian-Container (Proxmox, LXC)

Locke
Beiträge: 165
Registriert: 14. Apr 2020 11:35
Answers: 3
Wohnort: bei Hamburg

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von Locke »

@Kellerkind
ja, im Router ist die IP fest vergeben für den Raspi.
Router und Raspi habe ich schon mehrmals neu gestartet ohne das sich etwas geändert hat.

@Udo
DHCP ist auf dem Raspi aktiv



Habe noch 2 Raspi laufen und da ist alles so wie es sein soll, mit den gleichen Einstellungen. Verstehe auch nicht wieso es plötzlich aufgetreten ist bei dem einem Raspi.
thnx
____Sven_________________________________________________________________________________________
Raspberry Pi 4, 4GB RAM, openHAB 2.5.10 / Raspberry Pi 4, 2GB RAM, openHAB 3.3.0 (zum Testen)

Benutzeravatar
udo1toni
Beiträge: 9813
Registriert: 11. Apr 2018 18:05
Answers: 131
Wohnort: Darmstadt

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von udo1toni »

Warum schaltest Du DHCP nicht ab? Entweder Adresse per DHCP zuweisen (und dann im DHCP Server die MAC fix zuordnen) oder eine statische IP vergeben, aber bitte nicht beides.

Eine mögliche Ursache könnte eine Änderung der MAC sein, das kann nach einem Kernel Upgrade passieren. Ich habe das aber auch schon "einfach so" gesehen. Die MAC ist individuell in der Hardware hinterlegt, es kann auch passieren, dass der Speicher einen Fehler hat und somit eine falsche MAC ausliefert.
openHAB2.5.12 in einem Debian-Container (Proxmox, LXC)

Benutzeravatar
KellerK1nd
Beiträge: 392
Registriert: 17. Jun 2019 16:45
Answers: 1
Wohnort: Griesheim

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von KellerK1nd »

Das mit der MAC-Adresse wäre jetzt auch eine Vermutung von mir. Wenn alles andere schon versucht wurde. Mal die MAC-Adresse im DHCP mit der vom Raspi vergleichen und gegebenenfalls anpassen. Sollte das identisch sein, würde ich über einen Rechner mal einen MAC Sniffer (Wireshark, oder ähnliches) nutzen und mal schauen was der Raspi alles ausspuckt.
Betriebssystem: Proxmox 7.2-3
openHAB Container: debian11 LXC
openHAB Version: 3.3
Hardware: HomeServer Eigenbau mit einem Intel i5 9600K
Smarthome-Equipment:
- Rasperrymatic
- deConz
- HUE
- Shellys
- Mosquitto
- AVM Fritz!Box

Locke
Beiträge: 165
Registriert: 14. Apr 2020 11:35
Answers: 3
Wohnort: bei Hamburg

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von Locke »

Gumo,
@Udo
wenn ich Dich richtig verstehe meinst Du sollte ich DHCP auf dem Raspi deaktivieren und unter network/interfaces die IP eintragen.

@Kellerkind
Ich werde später die Mac Adresse kontrollieren und mal den Tip mit einem Sniffer probieren.

EDIT:

die MAC Adresse ist die richtige bei beiden IP's

Geräte im LAN

Name: Openhabian Server
IPv4: 192.168.123.143
IPv6: 2a02:8108:1500:6594::f269
MAC: dc:a6:32:0a:c5:b6
Geschwindigkeit: 1 Gbps

Statisches DHCP - Heimnetzwerk

Openhabian Server
MAC: DC:A6:32:0A:C5:B6
IPv4: 192.168.123.141


Ich habe jetzt noch ein Problem mit meinem Test Raspi, evtl. habt ihr auch hierfür eine Idee.
Es läuft auf dem Raspi Openhabian mit OH 3.2 welches auch läuft und ich auch darauf zugreifen kann.
Leider komme ich über Terminal nicht mehr auf den Raspi mit 2 Rechnern probiert.
Starte ich den Raspi neu (Hardreset) funktioniert es wieder für eine gewisse Zeit. Auf OpenHAB kann ich zugreifen und auch bearbeiten.
Werde später mal sehen das ich einen Monitor direkt an den Raspi bekomme.
Weiß nicht was hier aufeinander los ist.

Danke euch
thnx
____Sven_________________________________________________________________________________________
Raspberry Pi 4, 4GB RAM, openHAB 2.5.10 / Raspberry Pi 4, 2GB RAM, openHAB 3.3.0 (zum Testen)

Benutzeravatar
udo1toni
Beiträge: 9813
Registriert: 11. Apr 2018 18:05
Answers: 131
Wohnort: Darmstadt

Re: Raspi Pi4 hat 2 ip Adressen

Beitrag von udo1toni »

Du kannst DHCP auf dem Raspberry deaktivieren oder die statische IP raus nehmen, beide Varianten sind in Ordnung. Beides gleichzeitig zu konfigurieren kann aber zu dem von Dir beschriebenen Problem führen, weil der DHCP Server vielleicht einfach eine andere IP zuweist.
Schlimmer noch, scheinst Du die IP auf dem Raspberry einfach fix im Raspberry gesetzt zu haben, aber sie scheint aus dem DHCP Adressbereich zu stammen, das ist nicht zulässig!
Der DHCP Server schert sich nicht um fix gesetzte IPs, er hat einen Block (konfigurierbar, z.B. 192.168.123.[2 - 200]) von Adressen, die er vergibt. Er prüft nicht, ob ein anderes Gerät diese Adresse bereits verwendet, er hat ja eine Liste der Adressen, die er selbst vergeben hat. Im Zweifel kann es so also passieren, dass die selbe IP auf zwei Geräten aktiv ist.
Und da der DHCP Server den Adressbereich reserviert hat, hat er auch Recht. Wenn Du also eine IP fix vergeben willst, nutze unbedingt eine außerhalb des DHCP-Blocks (aber innerhalb des Subnetzes).

Gerade im Heimnetz bietet es sich an, die IP-Adressen der Geräte zentral über den DHCP Server zu konfigurieren. Je nach Router (meist ist das gleichzeitig auch der DHCP Server) wird das unterschiedlich konfiguriert, aber fast alle Router am Markt bieten diese Option, manchmal versteckt, z.B. im Menü für Portweiterleitungen (weil diese eine fixe IP im LAN voraussetzen).

Was den zweiten Pi betrifft, so kann ich nur vermuten, dass Du hier vielleicht auch ein DHCP Problem hast. Je nachdem kann das Problem z.B. nach Ablauf der Lease-Zeit auftreten, der Pi verliert also seine IP-Adresse, weil ein Fehler in der IP-Konfiguration vorliegt. Nach einem Neustart funktioniert es dann für eine kurze Zeit. Die Lease-Zeit ist meist auf eine Stunde eingestellt, aber das variiert auch von Hersteller zu Hersteller, und in einem LAN kann der Anwender natürlich auch kürzere oder längere Lease-Zeiten selbst vorgeben (immer im DHCP Server).

Alternativ könnte auch der SSH-Server selbst abstürzen, das wäre aber eher ungewöhnlich und würde für mich erst mal auf eine defekte SD-Karte hindeuten, weil openSSHd eigentlich super stabil ist, da läge dann ein Fehler im Dateisystem als Ursache nahe.
openHAB2.5.12 in einem Debian-Container (Proxmox, LXC)

Antworten