Zigbee2MQTT will nicht, lauter Fehler

Moderatoren: seppy, udo1toni

Antworten
D3ltorohd
Beiträge: 18
Registriert: 7. Apr 2019 19:31

Zigbee2MQTT will nicht, lauter Fehler

Beitrag von D3ltorohd » 14. Mai 2019 18:25

Hallo Com,

ich habe nun versucht meinen Zigbee Stick mit dem zigbee2mqtt Script zu betreiben, nachdem es mit dem Zigbee Binding unter OH nicht funktioniert (Findet meinen Mijia Fenster Sensor von Xiaomi nicht) leider stimmt hier schon was bei der Installation nicht. Dort gibt es Fehler und auch wenn ich es ausführen will, gibt's nen haufen Errors.

Kann einer sehen, was ich falsch gemacht habe ? Bin nach der Install Anleitung https://www.zigbee2mqtt.io/getting_star ... 2mqtt.htmlvorgegangen.

Grüße

Bild

Bild

StefanH.
Beiträge: 115
Registriert: 28. Dez 2017 11:37

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von StefanH. » 17. Mai 2019 21:12

aus dem Bauchgefühl würde ich sagen mit deiner Konfigurationsdatei stimmt was nicht. Was hast du denn da editiert? Vielleicht ein Leerzeichen oder so zuviel?

D3ltorohd
Beiträge: 18
Registriert: 7. Apr 2019 19:31

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von D3ltorohd » 18. Mai 2019 11:15

StefanH. hat geschrieben:
17. Mai 2019 21:12
aus dem Bauchgefühl würde ich sagen mit deiner Konfigurationsdatei stimmt was nicht. Was hast du denn da editiert? Vielleicht ein Leerzeichen oder so zuviel?
Hm, ich hatte die Config wie im Video Tut beschrieben komplett gelöscht und mit copy and paste neu beschrieben.

Hier mal wie sie aussieht.

Code: Alles auswählen

# Required: Home Assistant integration (MQTT discovery)
homeassistant: false
# Required: allow new devices to join.
# WARNING: Disable this after all devices have been paired!
permit_join: true
# Required: MQTT settings
mqtt:
# Required: MQTT base topic for zigbee2mqtt MQTT messages
base_topic: zigbee2mqtt
# Required: MQTT server URL
server: 'mqtt://localhost:1883'
# Optional: MQTT server authentication user
user: my_user
# Optional: MQTT server authentication password
password: my_password
# Optional: MQTT client ID
client_id: 'Zigbee'
# Disable self-signed SSL certificates
reject_unauthorized: true
# Optional: Include device information to mqtt messages (default: false)
include_device_information: true
# Required: serial settings
serial:
# Required: location of CC2531 USB sniffer
port: /dev/ttyACM0
# Optional: disable LED
disable_led:false
User und Passwort habe ich nicht vergeben bei meinem MQTT Broker.
Hier steht zwar in der Config was drin, aber habe das so verstanden, das man halt was eintragen muss, auch wenn nichts im MQTT Broker steht.

mamoel
Beiträge: 132
Registriert: 12. Jan 2019 19:56

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von mamoel » 18. Mai 2019 11:17

Welche Hard- und Software hast Du denn als Grundlage?

Meine config:

Code: Alles auswählen

homeassistant: false
permit_join: false
mqtt:
  base_topic: zigbee2mqtt
  server: 'mqtt://localhost'
  include_device_information: false
serial:
  port: /dev/ttyACM0
  disbale_led: true
advanced:
  channel: 20
  last_seen: ISO_8601_local
Danach kommen noch die devices, aber die helfen Dir nicht weiter.
openHAB 2.5 (M1) in Docker auf NAS: Synology DS418play
mit Homematic, Hue, TP-Link, AVM Fritz!, FritzboxTR064, Nuki, Amazon Echo, Sonos, Harmony, zigbee2mqtt, Denon/Marantz, ...

D3ltorohd
Beiträge: 18
Registriert: 7. Apr 2019 19:31

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von D3ltorohd » 18. Mai 2019 12:04

Ich habe nen Intel NUC 5PPYH und Debian 9 wars glaub.

Ich schmeiße einfach mal deine Config rein.

EDIT::

Ich habe die Config noch mal neu geschrieben in Notepad++ and put it to the System. So for now i have the following Error..

Error while starting zigbee-shepherd, attemping to fix... (takes 60 seconds) After this some more errors.

mamoel
Beiträge: 132
Registriert: 12. Jan 2019 19:56

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von mamoel » 18. Mai 2019 13:36

Auf einem NUC hast Du doch genügend Ressourcen, um zigbee2mqtt in einem Docker Container laufen zu lassen. Das macht die Sache wesentlich komfortabler.
openHAB 2.5 (M1) in Docker auf NAS: Synology DS418play
mit Homematic, Hue, TP-Link, AVM Fritz!, FritzboxTR064, Nuki, Amazon Echo, Sonos, Harmony, zigbee2mqtt, Denon/Marantz, ...

D3ltorohd
Beiträge: 18
Registriert: 7. Apr 2019 19:31

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von D3ltorohd » 18. Mai 2019 19:44

mamoel hat geschrieben:
18. Mai 2019 13:36
Auf einem NUC hast Du doch genügend Ressourcen, um zigbee2mqtt in einem Docker Container laufen zu lassen. Das macht die Sache wesentlich komfortabler.
Oh je, ich bin totaler Anfänger was Linux angeht, ka was Docker ist und warum es damit komfortabler ist ?
Hättest du mir dazu vllt ein wenig Hilfestellung ? Ist Docker bei Debian dabei, muss ich das extra installieren ?

mamoel
Beiträge: 132
Registriert: 12. Jan 2019 19:56

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von mamoel » 18. Mai 2019 20:11

Da müsste ich sehr weit ausholen, aber wie man es installiert kannst du z.B. hier nachlesen https://www.digitalocean.com/community/ ... n-debian-9

Ich würde dir empfehlen, einfach mal ein wenig zum Thema Docker zu googeln.
openHAB 2.5 (M1) in Docker auf NAS: Synology DS418play
mit Homematic, Hue, TP-Link, AVM Fritz!, FritzboxTR064, Nuki, Amazon Echo, Sonos, Harmony, zigbee2mqtt, Denon/Marantz, ...

D3ltorohd
Beiträge: 18
Registriert: 7. Apr 2019 19:31

Re: Zigbee2MQTT will nicht, lauter Fehler

Beitrag von D3ltorohd » 18. Mai 2019 21:20

Ich habs, es läuft nun auch ohne Docker.

Als erstes war die Config wohl falsch, irgendwas hat da nicht gepasst, nach erneutem Kopieren und editieren hat es funktioniert, der zweite Fehler war, das in OH das Zigbee Binding auf den Stick Zugriff und somit Zigbee2mqtt nicht mehr konnte.

Aber auch hier scheine ich meinen Mijia Door Sensor von Xiaomi nicht pairen zu können. Muss ich mir mal nen Aqara besorgen, ob es mit dem vllt geht.

Danke euch allen für die Tipps und Hilfen.

Antworten

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast